When refactoring the name of the GWT module (which typically involves changing the name of the Module.gwt.xml file, see this post) you also have to change the returned value from getModuleName() in every GWTTestCase:
This is way I usually factor the name of the module out into a utility class, and reference a static constant from every test case: saves a lot of pain and effort following some heavy refactoring.
If you do want to watch the video, here’s a few tips:
- if your connection is fast enough, choose 720p as the resolution, or the various menu items and text in general, will be very blurry;
- this is best viewed full-screen;
- a description as to how to create a reusable GWT Module can be found here